R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 06-28-2006, 04:11 PM   #1
Tech Apprentice
Join Date: Apr 2006
Posts: 67
Default Problem with xxxs

Ok the radio will only turn the car left, what should I do?
rclover#0000001 is offline   Reply With Quote
Old 06-28-2006, 04:58 PM   #2
Tech Champion
stiltskin's Avatar
Join Date: Jun 2005
Location: Virginia Beach
Posts: 5,298
Trader Rating: 97 (100%+)

Disconnect the servo horn and make sure that you have full travel mechanically. Check the trim settings on your radio. Set your steering trim to neutral and center the servo. Install the horn again and listen for any grinding in the servo. If still no worky worky, try a different servo.
Tony Rumple
Team EAM // Gravity RC
stiltskin is offline   Reply With Quote
Old 06-28-2006, 09:05 PM   #3
Tech Master
pinggoy's Avatar
Join Date: Mar 2006
Location: WBP Florida
Posts: 1,263
Trader Rating: 24 (96%+)
Send a message via Yahoo to pinggoy

pinggoy is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Team Losi XXXS problem - very high pitch noise newm5 Electric On-Road 4 09-12-2006 10:30 AM
XXXS GP race car and XXXS GP parts car RussB R/C Items: For Sale/Trade 0 08-08-2005 09:48 PM
ATTN XXXS Owners and lovers... XXXS BODIES!!! Keith Billanti R/C Items: For Sale/Trade 4 01-28-2005 01:41 PM
XXXS belt problem speedmachine Singapore R/C Racers 3 12-23-2002 09:28 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 01:20 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0