R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 04-24-2006, 08:33 PM   #1
Tech Regular
viet_mafia's Avatar
Join Date: Dec 2005
Posts: 382
Default Novak GTB Problems

Hi, I recently bought a second-hand GTB 5.5 Brushless System and I tried it out for the first time today but it was having these wierd problems. Sometimes the throttle would work, other times it wouldn't and the blue LED would blink suggesting a locked rotor.....but the drivetrain is completely free, the funny thing is that if i give it some throttle and push the car with my foot to get it rolling it actually gets power I have no idea what could be wrong with it....the setups are all ok, but it looks like the previous owner tried running the brushless without a power cap and melted a bit of the plastic on the case, other than that once it gets going it works perfectly fine.

i have a new power cap.....or more like two 10v/4700uF power caps wired in parallel for a dual throttle look and some good cappage performance the motor also sounds like it has some rough cogging in the low revs....not sure if it has anything to do with the locked rotor detection problem or not...
Can anyone help?
viet_mafia is offline   Reply With Quote
Old 04-24-2006, 09:13 PM   #2
Tech Regular
tr1kstanc3's Avatar
Join Date: Aug 2005
Location: Virginia
Posts: 357
Trader Rating: 18 (100%+)

what it means is that you have a burnt out mosfet on your speed controller. it does not fire up when the rotor is in a certain position. you need to take it back to novak for service. i had this problem with my first 5.5r system and that is the explanation i got. same exact symptoms as yours.
☆ Joe Tran ☆
tr1kstanc3 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Novak GTS Problems TylerOwenby Electric On-Road 8 06-27-2007 01:19 PM
novak SS+ ESC and SS5800 motor problems bibleboy Electric On-Road 1 12-31-2006 08:44 PM
Ice Charging w/ novak bars. Novak equilizer problems Khan48 Electric Off-Road 4 12-24-2005 10:50 PM
Novak Smart Tray problems Khan48 Electric On-Road 9 11-17-2005 06:02 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 11:07 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0