R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 06-03-2008, 04:33 PM   #6091
Tech Regular
 
Join Date: Jul 2002
Location: England
Posts: 417
Send a message via MSN to Bigger Brother
Default

Hi Rick
If its not too much trouble could you send me a copy of your setup sheet also, oli.meggitt@gmail.com Many thanks
Oli, UK
__________________
Oli Meggitt | London, UK
.:. Essex Winter Series .:. CML Racing .:. ToniSport .:. Zen Racing .:. Moorespeed RC .:. OTM Racing .:. RC Racing TV .:. RIDE R/C Scoreboards
Bigger Brother is offline   Reply With Quote
Old 06-03-2008, 06:24 PM   #6092
Tech Elite
 
wallstreet's Avatar
 
Join Date: Mar 2005
Posts: 3,904
Trader Rating: 20 (92%+)
Send a message via AIM to wallstreet
Default

Rick can you email me your setup from the reedy race.

Or if one of you guys who asked for the setup from rick and got it you can send it to me .

thanks

mikestewart1710@gmail.com
wallstreet is offline   Reply With Quote
Old 06-03-2008, 06:51 PM   #6093
Tech Master
 
Join Date: Sep 2003
Location: Whitmore lake, mi
Posts: 1,204
Trader Rating: 43 (100%+)
Default

what is the JAAD spool where do i find one

i would also like reedy set up email is jshort_420@yahoo.com
thanks
josh short is offline   Reply With Quote
Old 06-03-2008, 07:06 PM   #6094
Tech Champion
 
Join Date: Oct 2005
Location: Cincinnati, OH
Posts: 5,360
Trader Rating: 38 (100%+)
Default

Quote:
Originally Posted by josh short View Post
what is the JAAD spool where do i find one

i would also like reedy set up email is jshort_420@yahoo.com
thanks
Unfortunately they dont have a distributor in the US (they make great products). I got mine here:

http://precisionrc.com/nv/car/produc...oduct_id=54280
or8ital is offline   Reply With Quote
Old 06-04-2008, 08:05 AM   #6095
Tech Master
 
johnny55's Avatar
 
Join Date: Apr 2003
Location: Temple City, Ca
Posts: 1,246
Trader Rating: 8 (100%+)
Send a message via AIM to johnny55
Default Rear Shocks

Hey guys wondering if I can get more help, well just finished building my car but one of my rear shocks has a slow leak, I replaced the bladder and the bigger round foam but didn't change the small one that goes on the cap, anyway it's still leaking, any suggestions? Do you think I didn't build the shock correctly mabe the bladder is on crooked is their an easier way of building them?, or is it the cap itself? Thanks in advance!!
johnny55 is offline   Reply With Quote
Old 06-04-2008, 09:30 AM   #6096
Tech Regular
 
overflow's Avatar
 
Join Date: Feb 2007
Location: Riverside, CA
Posts: 356
Trader Rating: 8 (100%+)
Default

Hey Guys, I normally run the standard chassis and ITF top deck, but I wanted to go back and try the ITF lower. Problem is when I tighten the top deck I get front to back tweak. Like a teeter-totter when on a flat surface. I have narrowed it down to when I tighten the top deck. No matter how hard I push the shock towers down when tightening it still pulls everything in. I have tried 2 top decks and I keep getting the same results. Any one else having the same problem or have even noticed this? I checked all my bulk heads for tweak and went as far as breaking the whole thing down to just chassis, bulkheads and top deck to eliminate other components. I have another chassis coming, but there isnt a lot of wear in this one.

Any one want to check theres out and let me know what you find.
Thanks All!
__________________
Dennis Vice

[HOTBODIES] [SPEED PASSION]
---------------------------------------------------------
overflow is offline   Reply With Quote
Old 06-04-2008, 09:42 AM   #6097
Tech Regular
 
katfish317's Avatar
 
Join Date: Mar 2008
Location: NC
Posts: 314
Trader Rating: 6 (100%+)
Default

Are you using the o-rings for the top deck??? I noticed this when I got my lower chassis installed, it was very minimal and did not seem too have this when using the o-rings in the top deck.

Johnny55:
I would try going to the another manufacturer bladder it seems too help seal better. Just my $.02(not saying the factory ones are bad )
katfish317 is offline   Reply With Quote
Old 06-04-2008, 09:51 AM   #6098
Tech Regular
 
overflow's Avatar
 
Join Date: Feb 2007
Location: Riverside, CA
Posts: 356
Trader Rating: 8 (100%+)
Default

Quote:
Originally Posted by katfish317 View Post
Are you using the o-rings for the top deck??? I noticed this when I got my lower chassis installed, it was very minimal and did not seem too have this when using the o-rings in the top deck.

Johnny55:
I would try going to the another manufacturer bladder it seems too help seal better. Just my $.02(not saying the factory ones are bad )
Yeah, its not alot of front to back movement, but its there. I tried the o-rings and it does stay flat with them. Just because the screw head is not going all the way down into the bevel.
__________________
Dennis Vice

[HOTBODIES] [SPEED PASSION]
---------------------------------------------------------
overflow is offline   Reply With Quote
Old 06-04-2008, 11:54 AM   #6099
Super Moderator
 
Kraig's Avatar
 
Join Date: Aug 2001
Location: Sun Prairie, WI
Posts: 6,302
Trader Rating: 69 (100%+)
Default

If you use the new washers that they are providing in the TC5R for the top deck you will elminate it on the car. Mine had the same problem and I still ran it. I have since switched my car to the washer setup like the 5R but haven't had a chance to run it yet but the problem went away.
__________________
There is great need for a sarcasm font.

You never know when it will strike, but there comes a moment at work when you know that you just aren't going to do anything productive for the rest of the day.

Sometimes I post just to look at my avatar.
Kraig is offline   Reply With Quote
Old 06-04-2008, 12:19 PM   #6100
Tech Regular
 
overflow's Avatar
 
Join Date: Feb 2007
Location: Riverside, CA
Posts: 356
Trader Rating: 8 (100%+)
Default

Quote:
Originally Posted by Kraig View Post
If you use the new washers that they are providing in the TC5R for the top deck you will elminate it on the car. Mine had the same problem and I still ran it. I have since switched my car to the washer setup like the 5R but haven't had a chance to run it yet but the problem went away.
Yeah, i have some on order. I am sure that will take care of it. Just didnt know if others were having the same problem.

Rick, or any other team drivers... Have you noticed this with your cars and do you just run with it?
__________________
Dennis Vice

[HOTBODIES] [SPEED PASSION]
---------------------------------------------------------
overflow is offline   Reply With Quote
Old 06-04-2008, 02:11 PM   #6101
Tech Master
 
PitNamedGordie's Avatar
 
Join Date: Nov 2003
Location: Highwood, IL
Posts: 1,788
Trader Rating: 8 (100%+)
Send a message via AIM to PitNamedGordie Send a message via Yahoo to PitNamedGordie
Default

Interesting upgrade....

http://www.redrc.net/2008/06/exotek-...-layshaft-set/

__________________
☆ The Track @ Harbor Hobbies ☆ www.harbor-hobby.net ☆
PitNamedGordie is offline   Reply With Quote
Old 06-04-2008, 02:12 PM   #6102
AE-Reedy
 
Join Date: May 2008
Posts: 752
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by overflow View Post
Yeah, i have some on order. I am sure that will take care of it. Just didnt know if others were having the same problem.

Rick, or any other team drivers... Have you noticed this with your cars and do you just run with it?
The chassis tweak really depends on the chassis and top decks some are perfect and some require a little adjusting. Check to make sure when you put the top deck on the bulkheads that there is some clearance between the ends of the graphite and the aluminum. It might require you the dremel a little graphite off, I have seen this cause some tweaks. If you get everything bolted together and the chassis is still not flat you might have to manually twist the chassis to help get it flat.
Sean Cochran is offline   Reply With Quote
Old 06-04-2008, 02:22 PM   #6103
Tech Regular
 
overflow's Avatar
 
Join Date: Feb 2007
Location: Riverside, CA
Posts: 356
Trader Rating: 8 (100%+)
Default

Quote:
Originally Posted by Sean Cochran View Post
The chassis tweak really depends on the chassis and top decks some are perfect and some require a little adjusting. Check to make sure when you put the top deck on the bulkheads that there is some clearance between the ends of the graphite and the aluminum. It might require you the dremel a little graphite off, I have seen this cause some tweaks. If you get everything bolted together and the chassis is still not flat you might have to manually twist the chassis to help get it flat.
Thanks Sean, Left to right is fine, its more of a slight bow upwards front to rear. I am going to look at a few more things tonight to see if i can get it to sit flat without the washers. I think i might bevel out the holes for the screws more so when i tighten, it doesnt pull it towerds center.
__________________
Dennis Vice

[HOTBODIES] [SPEED PASSION]
---------------------------------------------------------
overflow is offline   Reply With Quote
Old 06-04-2008, 02:36 PM   #6104
Tech Fanatic
 
fatbear's Avatar
 
Join Date: Nov 2003
Location: Perth, Western Australia
Posts: 804
Trader Rating: 10 (100%+)
Send a message via Yahoo to fatbear
Default

From what I have seen it is quite common to have that front to rear banana tweak. I have gone beyond the point of worrying about it.
fatbear is offline   Reply With Quote
Old 06-04-2008, 03:33 PM   #6105
Tech Fanatic
 
TeckLancer's Avatar
 
Join Date: Sep 2007
Location: Riverside CA
Posts: 972
Trader Rating: 16 (100%+)
Default

do u guys know could bind in the tc5 ? i pretty sure mine isnt but my motor is coming off the track real real hot and i can figure why im running a 6.26 final at a parking lot track and just comes off hot. ive tried everything.

any suggestions?
__________________
Eric Arellano
TC5,RC18-b,PRO4,FS,EIGHT-E 2.0,TLT,TF-5,Nitro MT
Panther tires, Speedtech r/c, Murfdogg Motorworks
check oout my forsale thread http://www.rctech.net/forum/r-c-items-sale-trade/401576-wts-b44-b4-losi-8e-hpi-nitro-mt-few-lipos.html
TeckLancer is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Team Losi XXXS G+ with parts!! Team Orion V2 Hitec 5625 cola R/C Items: For Sale/Trade 9 06-18-2008 08:11 PM
BATTERIES - Team Orion 4200 SHO Team Cells (6 cell) packs................... For Sale 2-Bad Australia For Sale/Trade 0 03-21-2008 02:16 AM
New Items for Sale Tamiya F103gt Chassis Kit, Team Much More CTX-D, Novak, Team Orion Tsquare R/C Items: For Sale/Trade 14 04-17-2007 08:29 PM
>>> BRAND STINKING NEW NEVER RAN TEAM JAMMIN FACTORY TEAM FTE RACING BUGGY <<<< mach51 R/C Items: For Sale/Trade 5 01-25-2007 09:13 PM
F/S Team Associated Factory Team RC18T with Mamba Comp X Brushless and Extras ZeroCool101 R/C Items: For Sale/Trade 7 01-07-2006 01:54 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 08:54 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0