R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 02-08-2006, 03:20 PM   #1
Tech Master
Mark G's Avatar
Join Date: Apr 2005
Location: chicago
Posts: 1,268
Trader Rating: 7 (100%+)
Send a message via AIM to Mark G
Default raido problems

I have a gt7 trying to get it set up with a Futaba R133F 3Ch FM 75MHz recever and its not working, do i need to change any thing. i uslay run a KO recever and it works fine just wanted to kno if i gota swich anything.
Mark G is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
futaba 3pm 2.4ghz raido system for sale hillbillyrcer R/C Items: For Sale/Trade 3 09-25-2007 05:00 PM
WTB- Spektrum Raido- Dx3.0, Dx3, Dx2 JollyJim Australia Wanted to Buy 1 06-20-2007 07:01 AM
Anyone ever had problems with LRP Tannerb Electric Off-Road 21 03-23-2007 11:33 AM
KO raido Good shape mike rc R/C Items: For Sale/Trade 1 03-08-2007 12:11 PM
IB3800,Tmaxx-Motors-Raido Mark G R/C Items: For Sale/Trade 14 05-27-2006 07:09 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 04:41 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0