R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 01-14-2006, 03:18 PM   #1
Tech Apprentice
backyardMT's Avatar
Join Date: Jan 2006
Posts: 77
Send a message via AIM to backyardMT
Default nitro mt trouble

i had broken the stock cluth on my hpi nitro rs4mt...and when i replaced it i put one of the parts on wrong...but when i went to take it apart again...it seems that the piece holding the clutch on is stuck on the threads....should i just keep prying and hope that it'll come off....or am i going to have to invest into a new engine? ...i'll try and get some pics of my problem tomorrow to further clarify what the deal is...any help would be great
backyardMT is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
having trouble pagmazdan Electric On-Road 2 05-10-2007 07:44 AM
Help im new and having trouble humourme999 Nitro On-Road 11 01-05-2007 01:06 AM
Will I be in trouble bring nitro engines to the airport? Solara Nitro On-Road 17 02-04-2005 01:57 AM
Trouble starting new Losi nitro truck joe-m Rookie Zone 3 07-14-2004 02:31 PM
Having Trouble!!!!! church Buyer/Seller dispute and Feedback discussion forum 6 12-12-2003 11:12 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 12:24 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0