R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 01-13-2006, 07:33 AM   #1
Tech Rookie
Join Date: Jan 2006
Posts: 5
Default brakes

how do i adjust my brakes for max performance when I race? the brake rod and or throttle rod that connects to the throttle servo has come off. I put it back on but cant seem to get my brakes to work good enough. my car takes off no matter what the idle rpm is it is just the power and force of my brakes.
RCMASTA is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
no brakes greenthumb1977 Nitro Off-Road 1 06-21-2008 04:31 AM
Top Driving Styles: Using Brakes and Drag Brakes SlamMan Electric On-Road 32 04-30-2007 10:11 PM
QC2 - No Brakes? Jam-ehz Electric On-Road 2 01-23-2006 01:12 PM
Need help with brakes jigga21 Monster Trucks 1 07-25-2005 02:56 AM
Brakes ? imjonah Electric On-Road 10 10-30-2004 07:54 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 08:37 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0