R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 03-01-2016, 12:37 AM   #1
Tech Adept
 
Join Date: Feb 2016
Posts: 123
Questions?? Help with RC8.2e

I just picked up a new Rc8.2e and on the first trip out I noticed the braking isn't strong at all. All my other RC experience is with a Slash and when I'm driving that I can hit the brakes hard enough to front flip it. I've never had a race kit before so I wasn't sure if that's how it's supposed to be or if it can be adjusted. I like my brakes pretty strong so I'm able to stop fast in a hairy situation.

Question 2.

I didn't realize that there wasn't going to be a reverse lol. I know it's a race kit and on the track there's no reversing but for practice purposes I was wondering if there's a way to turn on reverse without buying a new ESC?

I know these are newb questions but I appreciate any help.
NitroSport85 is offline   Reply With Quote
Old 03-01-2016, 05:50 PM   #2
Tech Adept
 
Join Date: Feb 2016
Posts: 123
Default

Bump 😞
NitroSport85 is offline   Reply With Quote
Old 03-01-2016, 06:51 PM   #3
Tech Master
 
M03Racer's Avatar
 
Join Date: Apr 2010
Location: Great Lakes
Posts: 1,187
Trader Rating: 33 (100%+)
Default

What ESC do u have and do U have instructions. If not u can look up instructions on line. I'm pretty sure its your ESC, just needs to be adjusted.
M03Racer is offline   Reply With Quote
Old 03-02-2016, 03:00 AM   #4
Tech Addict
 
blarks's Avatar
 
Join Date: Aug 2014
Location: Beyond the outer rim
Posts: 597
Trader Rating: 29 (100%+)
Default

Yes, what MO3 has said, you need to check what your brake settings are on the esc, if your finding them inadequate then its most probably at a low brake % And the same will be with your reverse, depending on the esc you should be able to select what driving mode you want, eg. for/rev, for/rev/brk etc.
__________________
I like rc cars big whoop wanna fight about it.
blarks is offline   Reply With Quote
Old 02-02-2017, 03:46 PM   #5
Tech Rookie
 
Join Date: Feb 2017
Posts: 6
Default Rc8.2e stops working about 50ft away

Just got a used rc8.2e rtr buggy for my daughter. It runs fine till you get about 50ft away then stops working till you walk closer to it. What is going on?
Pnichalos is offline   Reply With Quote
Old 02-03-2017, 02:52 AM   #6
Tech Regular
R/C Tech Elite Subscriber
 
Join Date: Nov 2015
Location: WA
Posts: 450
Trader Rating: 30 (100%+)
Default

Double check and make sure transmitter batteries are fully charged or new. Might possible have a bad transmitter,receiver and or a broken (damaged) antenna wire.
Propchecku37 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:39 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net