R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Like Tree16Likes
Reply
 
Thread Tools Search this Thread
Old 04-20-2015, 05:15 PM   #616
Tech Addict
 
gogi108's Avatar
 
Join Date: Feb 2011
Location: brisbane
Posts: 607
Trader Rating: 9 (100%+)
Default

.
__________________
Tlr 22 2.0,losixx4we,xxx4g, 22-4
Chargers RC
Trackside rc

Last edited by gogi108; 04-20-2015 at 05:56 PM. Reason: found
gogi108 is offline   Reply With Quote
Old 04-20-2015, 06:44 PM   #617
Tech Regular
 
Join Date: Aug 2010
Posts: 453
Trader Rating: 26 (96%+)
Default mugen

So I just finished my build this past Saturday on my new mugen 7r eco , very disappointed, the motor mount is an issue , the Ackerman hitting diff case is an issue , and the rear springs is an issue , it's hard for a car to perform at it's best if it has issues . The rear springs annoy me the most , suspesion has to be free as possible to perform the way it was designed too , it binds up on the shocks , how is it going to get rear traction if it gets hung up ? I went to the track after build and it wouldn't turn as tight as it should have because of the diff case , it will wear in? That's a joke , so I have to do what two races by the time it wears in? I didnt spend $550 for a half thought out car , I'm a huge mugen fan , it's the only car that works for me , I know some cars have some bugs , but it's after the build not during the build , just wanted to vent . I'm glad ppl get on here because the problems that I was having so was a lot of other ppl, great info guys
ldog is offline   Reply With Quote
Old 04-20-2015, 07:03 PM   #618
Tech Adept
 
Join Date: Apr 2012
Location: NC
Posts: 229
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by ldog View Post
So I just finished my build this past Saturday on my new mugen 7r eco , very disappointed, the motor mount is an issue , the Ackerman hitting diff case is an issue , and the rear springs is an issue , it's hard for a car to perform at it's best if it has issues . The rear springs annoy me the most , suspesion has to be free as possible to perform the way it was designed too , it binds up on the shocks , how is it going to get rear traction if it gets hung up ? I went to the track after build and it wouldn't turn as tight as it should have because of the diff case , it will wear in? That's a joke , so I have to do what two races by the time it wears in? I didnt spend $550 for a half thought out car , I'm a huge mugen fan , it's the only car that works for me , I know some cars have some bugs , but it's after the build not during the build , just wanted to vent . I'm glad ppl get on here because the problems that I was having so was a lot of other ppl, great info guys
I emailed them about my motor mount and they said it wasn't normal. Supposedly they are gonna send me a new one and have me send mine back. I'm not sure how long that is gonna take.

What problems were you having with your motor mount?
__________________
MBX7R Eco--Tekin Gen 2 1900kv, RC10B5m Factory Lite on order, Hitec Lynx 4s


All sold: RC8.2E--Tekin RX8 1900kv, DEX408--Tekin RX8 1900kv, SC104x4--RX8 Pro4 4000kv, E-Revo Brushless, Hpi Sprint 2 Drift, Airtronics mt-4,
jjahn is offline   Reply With Quote
Old 04-20-2015, 07:11 PM   #619
Tech Regular
 
Join Date: Aug 2010
Posts: 453
Trader Rating: 26 (96%+)
Default

When you mount the motor mount to the motor it's tight up against the motor so when you try to do the gear mesh it doesn't slide because it puts pressure on it so it won't slide . You have to shave it down in order for it to work properly.
ldog is offline   Reply With Quote
Old 04-20-2015, 07:22 PM   #620
Tech Regular
 
Join Date: Aug 2010
Posts: 453
Trader Rating: 26 (96%+)
Default

The rear shocks springs rubbing is really another big problem , they go 16 mm because everybody else is putting 16 mm shocks on the other cars and then they use the springs from the old 15 mm shocks? That's halfa**, they had great idea with the car but executed it poorly . I waited for my kit for 2 months and this is what I get ? Springs rubbing on shock bodies, Ackerman hitting diff case , and then the motor mount ? Just disappointed
ldog is offline   Reply With Quote
Old 04-20-2015, 07:26 PM   #621
Tech Adept
 
Join Date: Apr 2012
Location: NC
Posts: 229
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by ldog View Post
The rear shocks springs rubbing is really another big problem , they go 16 mm because everybody else is putting 16 mm shocks on the other cars and then they use the springs from the old 15 mm shocks? That's halfa**, they had great idea with the car but executed it poorly . I waited for my kit for 2 months and this is what I get ? Springs rubbing on shock bodies, Ackerman hitting diff case , and then the motor mount ? Just disappointed
I hear you, I was disappointed too.
__________________
MBX7R Eco--Tekin Gen 2 1900kv, RC10B5m Factory Lite on order, Hitec Lynx 4s


All sold: RC8.2E--Tekin RX8 1900kv, DEX408--Tekin RX8 1900kv, SC104x4--RX8 Pro4 4000kv, E-Revo Brushless, Hpi Sprint 2 Drift, Airtronics mt-4,
jjahn is offline   Reply With Quote
Old 04-20-2015, 07:27 PM   #622
Tech Adept
 
Join Date: Apr 2012
Location: NC
Posts: 229
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by ldog View Post
When you mount the motor mount to the motor it's tight up against the motor so when you try to do the gear mesh it doesn't slide because it puts pressure on it so it won't slide . You have to shave it down in order for it to work properly.
Yeah I had the exact same problem, which mugen support claimed shouldn't have been that way.
__________________
MBX7R Eco--Tekin Gen 2 1900kv, RC10B5m Factory Lite on order, Hitec Lynx 4s


All sold: RC8.2E--Tekin RX8 1900kv, DEX408--Tekin RX8 1900kv, SC104x4--RX8 Pro4 4000kv, E-Revo Brushless, Hpi Sprint 2 Drift, Airtronics mt-4,
jjahn is offline   Reply With Quote
Old 04-21-2015, 06:49 AM   #623
Tech Initiate
 
Join Date: Feb 2015
Location: South Texas
Posts: 24
Default

Quote:
Originally Posted by ldog View Post
The rear shocks springs rubbing is really another big problem , they go 16 mm because everybody else is putting 16 mm shocks on the other cars and then they use the springs from the old 15 mm shocks? That's halfa**, they had great idea with the car but executed it poorly . I waited for my kit for 2 months and this is what I get ? Springs rubbing on shock bodies, Ackerman hitting diff case , and then the motor mount ? Just disappointed
I think it is the spring that particular spring that comes with the car. I am running the softer 8.75 turn/coil silver rear springs and the 8.25 turn/coil silver front springs. They are a softer spring. I am running a light weight battery pack and needed the softer springs. The light springs collapse very even and does not bow under compression. There is no rubbing and they work perfect. The factory setup springs in the rear bow as they compress and then will rub on the threaded portion of the body. I think a larger wire size with more coils would have prevented the spring from bowing under compression and rubbing on the bodies. I think it boils down to to few coils for the wire size in the stock rear spring.

Last edited by Al_T; 04-21-2015 at 09:52 AM.
Al_T is offline   Reply With Quote
Old 04-21-2015, 07:05 AM   #624
Tech Rookie
 
Join Date: Mar 2015
Posts: 1
Default rear hub set screw

what is the set screw in the rear hub for? and how should it be adjusted...
cneptune is offline   Reply With Quote
Old 04-21-2015, 07:31 AM   #625
Tech Adept
 
TLR_TeknoRC's Avatar
 
Join Date: Sep 2014
Location: AUSTRALIA
Posts: 226
Trader Rating: 1 (100%+)
Default

is mugen address this issue?

motor mount-not sliding correctly
shock springs-rubbing the shock body
ackermann-hitting the diff case

is somebody out there to enlighten us mugen fan, users and racer?
TLR_TeknoRC is offline   Reply With Quote
Old 04-21-2015, 10:17 AM   #626
Tech Elite
 
hairymuffin's Avatar
 
Join Date: Feb 2008
Location: moreno valley, ca
Posts: 2,647
Trader Rating: 93 (100%+)
Default

Quote:
Originally Posted by TLR_TeknoRC View Post
is mugen address this issue?

motor mount-not sliding correctly
shock springs-rubbing the shock body
ackermann-hitting the diff case

is somebody out there to enlighten us mugen fan, users and racer?
there is not one car on the market that the springs don't rub the shock. bodies..someone covered this before with pics off all the cars..get the 16mm springs,still gonna rub,but no big deal...you can't have perfection,also someone covered the solution to the motor mount some pages ago..on my old eco6 i put small shims between the motor,problem solved.. sometimes a little hand fitting is required,also as a hobbiest ,invest in a dremel..as a pro driver,i will say that the springs is not an issue...you have to let the car wear in,mugens get better with age.. send Adam drake an email,he posted his email address on the intro thread..
hairymuffin is offline   Reply With Quote
Old 04-21-2015, 10:28 AM   #627
Tech Master
 
egobrkr's Avatar
 
Join Date: Jul 2012
Posts: 1,863
Trader Rating: 26 (100%+)
Default

I have had numerous kits of different brands. Every one of them the springs rubbed. I have not had any issues with the motor mount not sliding on the x7r, the x7 or x6 ecos nor does the one I built for a local. The diff case is and issue on the eco and the nitro. I just sanded down a little of the diff case and all is good. In my opinion saying this kit is a disappointment is a little much. I have built losi, tekno, hotbodies and AE kits and they all had little issues that had to be addressed. In my opinion it's part of the hobby.
__________________
Mugen MBX7R Triton L5 Picco 2120 pipe M2C clutch
Mugen MBX7T Triton L5 Triton 2120 pipe M2C clutch
Mugen MBX7R Eco Tekin RX8 Gen2 Tekin 2050kv
youtube.com/user/egobrkr
Thanks to my sponsors Mugen Seiki and Radiopost
egobrkr is offline   Reply With Quote
Old 04-21-2015, 12:16 PM   #628
Tech Regular
 
Jason Baliban's Avatar
 
Join Date: Jul 2014
Location: Eastern PA
Posts: 314
Default

Quote:
Originally Posted by TLR_TeknoRC View Post
is mugen address this issue?

motor mount-not sliding correctly
shock springs-rubbing the shock body
ackermann-hitting the diff case

is somebody out there to enlighten us mugen fan, users and racer?
I guess the RC8B3 is going to have these three issues as well?!

Couldnt resist!

My 7Re is en route! Cant wait!

jB
__________________
High Sundry Productions

B5M | MBX-7Re | T5M | TC3 | RC10 "Graphite"
Jason Baliban is offline   Reply With Quote
Old 04-21-2015, 12:29 PM   #629
Tech Adept
 
Join Date: Apr 2012
Location: NC
Posts: 229
Trader Rating: 1 (100%+)
Default

Just received my replacement motor mount. The issues I was having and others have said the had according to Mugen aren't normal, but if I still have the problem I will just shim the motor like was mentioned above.

Also I said I was disappointed due to my expectations, not that the kit was a disappointment. Overall I think this is high quality. I am not having an issue with the ackermann hitting, at least it's not noticeable or affecting performance, but that seems like an odd thing to overlook.

There are too many things to list that are better on this kit than the rc8.2e I built previously. Also, customer support has been great, and that goes a long way to me.
__________________
MBX7R Eco--Tekin Gen 2 1900kv, RC10B5m Factory Lite on order, Hitec Lynx 4s


All sold: RC8.2E--Tekin RX8 1900kv, DEX408--Tekin RX8 1900kv, SC104x4--RX8 Pro4 4000kv, E-Revo Brushless, Hpi Sprint 2 Drift, Airtronics mt-4,
jjahn is offline   Reply With Quote
Old 04-21-2015, 04:01 PM   #630
Tech Master
 
egobrkr's Avatar
 
Join Date: Jul 2012
Posts: 1,863
Trader Rating: 26 (100%+)
Default

Quote:
Originally Posted by jjahn View Post
Just received my replacement motor mount. The issues I was having and others have said the had according to Mugen aren't normal, but if I still have the problem I will just shim the motor like was mentioned above.

Also I said I was disappointed due to my expectations, not that the kit was a disappointment. Overall I think this is high quality. I am not having an issue with the ackermann hitting, at least it's not noticeable or affecting performance, but that seems like an odd thing to overlook.

There are too many things to list that are better on this kit than the rc8.2e I built previously. Also, customer support has been great, and that goes a long way to me.
Glad you got the new part. The ackerman hitting the diff case did not cause any performance issues for me. I noticed marks on the diff case after I took the kit apart for a cleaning. I just sanded those spots a little so it does not hit anymore.
__________________
Mugen MBX7R Triton L5 Picco 2120 pipe M2C clutch
Mugen MBX7T Triton L5 Triton 2120 pipe M2C clutch
Mugen MBX7R Eco Tekin RX8 Gen2 Tekin 2050kv
youtube.com/user/egobrkr
Thanks to my sponsors Mugen Seiki and Radiopost
egobrkr is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 10:12 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net