R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Like Tree2Likes
Reply
 
Thread Tools Search this Thread
Old 01-14-2015, 08:45 PM   #166
Tech Apprentice
 
Join Date: Sep 2013
Posts: 61
Default

Just so people don't think my rant was unjustified I'll give you guys an example of how thing work here in Australia. I have in the past and will in the future still deal with my LHS but mainly with items they have in stock. I'll take an order of say ten parts to the shop. The owner may not have enough of an order to put those ten parts through so waits until he has enough to make it worthwhile, this could be a week or more. Once he has enough the order is put through and processed by the importer which may take another week or two before it arrives back at the hobby shop, by this time if could be a month later. At this point I may or may not receive a call telling me the parts I ordered are here. Once I've found out there's something at the shop for me I either have to drive the 250km round trip to the shop or get them to post it on at extra freight cost to find that the importer only sent three of the parts that I really needed. I find it much easier to get onto a website click on add to cart and know that part is in stock and will be sent with the rest of the order I want to my doorstep within a week or two from anywhere in the world generally. I hope this sheds a little light over my ranting.
chktm is offline   Reply With Quote
Old 01-14-2015, 09:16 PM   #167
Tech Apprentice
 
Edintheclouds's Avatar
 
Join Date: Nov 2014
Location: Pottstown
Posts: 50
Default bought it. destroyed it.

Car was really fun with a 17.5 and I shredded it up and down my alley but it's not suitable for today's tracks. Or is it....
Edintheclouds is offline   Reply With Quote
Old 01-14-2015, 11:43 PM   #168
Tech Apprentice
 
Join Date: Sep 2013
Posts: 61
Default

Quote:
Originally Posted by Edintheclouds View Post
Car was really fun with a 17.5 and I shredded it up and down my alley but it's not suitable for today's tracks. Or is it....
Sounds like you are going to find out? I'm going to give it a go, I don't think taking on the biggest jumps on a 1/8 scale track would be wise but certain jumps would be fine. I think it could compete against more modern buggies or SC trucks and be a lot of fun. The buggy handles pretty awesome and puts the power of my 9.5t down well while cornering on rails. I curious to see how it'll go even against four wheel drives. Here it is on my home track, the biggest jump isn't huge but it's a lot bigger than what was around in the 80s lol.
http://m.youtube.com/watch?v=d1B6EHCnA3I#
http://youtu.be/yYid1Ktc0E4
chktm is offline   Reply With Quote
Old 02-02-2015, 12:35 PM   #169
Tech Master
 
kaiser's Avatar
 
Join Date: Sep 2010
Location: new milford ct
Posts: 1,688
Trader Rating: 2 (100%+)
Default

here's mine, ready for battle.
currently just a 17.5 in there.
Attached Thumbnails
Kyosho Scorpion re-release-scorp1.jpg  
__________________
vintage for life! Jrx2/JrxPro/RC10/RC10ce/RC10 graphite/RC10 oin/RC10T/RC10T2/RCPS sprinter/Optima x2/Scorpion/too many old tamiya's to list
RCHR.biz
kaiser is offline   Reply With Quote
Old 03-15-2015, 08:48 PM   #170
Tech Adept
 
jgGonzo's Avatar
 
Join Date: Mar 2008
Location: Wisconsin
Posts: 165
Trader Rating: 27 (100%+)
Default

Love my Beetle

Last edited by jgGonzo; 03-18-2015 at 05:06 PM.
jgGonzo is offline   Reply With Quote
Old 03-22-2015, 07:10 AM   #171
Tech Elite
 
JatoTheRipper's Avatar
 
Join Date: Sep 2007
Location: PA
Posts: 2,340
Trader Rating: 7 (100%+)
Default

I'm not happy with the low quality of the Scorpion kit at all. People always say how Kyosho kits are the highest quality, but that doesn't apply here.

So far I've had burrs on the metal parts, an unfinished suspension arm, short on hardware, and now this severe bind in the rear suspension.

I've loosened and tightened the suspension mounts and transmission at least 10 times with no success. Any ideas how to fix this? Please help. Thanks.
__________________
Leaf Spring Mafia - Member #1
https://www.shapeways.com/shops/leafspringmafia
https://www.facebook.com/LeafSpringMafia
https://www.instagram.com/LeafSpringMafia
JatoTheRipper is online now   Reply With Quote
Old 03-22-2015, 08:58 AM   #172
Tech Elite
 
Raman's Avatar
 
Join Date: Aug 2007
Location: Las Vegas
Posts: 3,206
Trader Rating: 56 (100%+)
Default

Quote:
Originally Posted by JatoTheRipper View Post
I'm not happy with the low quality of the Scorpion kit at all. People always say how Kyosho kits are the highest quality, but that doesn't apply here.

So far I've had burrs on the metal parts, an unfinished suspension arm, short on hardware, and now this severe bind in the rear suspension.

I've loosened and tightened the suspension mounts and transmission at least 10 times with no success. Any ideas how to fix this? Please help. Thanks.
The problem is the dog bones.. they are slightly too long. After you run the car for a while, it will smooth itself out.
__________________
TRF419X / Pulse 17.5, T.O.P Racing Sabre Mini AWD / Impact 21.5, M06 Pro / Impact 21.5, XV-01 Pro Rallye / Kinetic 17.5
Raman is offline   Reply With Quote
Old 03-28-2015, 02:19 PM   #173
Tech Regular
R/C Tech Elite Subscriber
 
Join Date: Apr 2014
Location: Orange County CA
Posts: 261
Trader Rating: 1 (100%+)
Default

I'm wondering if the new universals will fix it.
scoobyrs25 is offline   Reply With Quote
Old 03-28-2015, 04:18 PM   #174
Tech Elite
 
JatoTheRipper's Avatar
 
Join Date: Sep 2007
Location: PA
Posts: 2,340
Trader Rating: 7 (100%+)
Default

Quote:
Originally Posted by scoobyrs25 View Post
I'm wondering if the new universals will fix it.
They make universals? Could be better or worse.

Is Tamiya PS-6 paint the closest yellow? What about the Duratrax yellow? They have a couple different shades.
__________________
Leaf Spring Mafia - Member #1
https://www.shapeways.com/shops/leafspringmafia
https://www.facebook.com/LeafSpringMafia
https://www.instagram.com/LeafSpringMafia
JatoTheRipper is online now   Reply With Quote
Old 03-29-2015, 03:27 AM   #175
Tech Apprentice
 
Join Date: Sep 2013
Posts: 61
Default

Quote:
Originally Posted by JatoTheRipper View Post
I'm not happy with the low quality of the Scorpion kit at all. People always say how Kyosho kits are the highest quality, but that doesn't apply here.

So far I've had burrs on the metal parts, an unfinished suspension arm, short on hardware, and now this severe bind in the rear suspension.

I've loosened and tightened the suspension mounts and transmission at least 10 times with no success. Any ideas how to fix this? Please help. Thanks.
Sorry to hear of your dramas. Is this bind severe over the whole travel or just binding around dogbones level? If it's severe over the whole travel I'd say the inner suspension mount is upside down, if it's only around bones level it'll be them. I grind a little off each end until there's no bind. My friend has the universals and I'm sure he didn't have the issue, he didn't mention it anyway.
chktm is offline   Reply With Quote
Old 03-29-2015, 09:35 AM   #176
Tech Rookie
 
Join Date: Mar 2015
Posts: 4
Default

Quote:
Originally Posted by asc6000 View Post
Of the 3 people running old Scorpions ?
First post for me on these forums. Just found out today about the Re-released Scorpion.
I have a vintage Scorpion that I got back in '83 from a guy who had been racing with it and done quite a few mods to it as well.
Haven't driven it for maybe 25 years now but I've had the idea back in my head for a long time to put a new gearbox on it to allow for new motors and get it running again.
Last time I drove it, it had a Le Mans 480 Gold motor, 8.4V battery and a mechanical resistor speed-control.

Now I find out that with the re-re they've also made a perfect mod-kit for my old Scorpion as well. Can't wait to get it updated and running again with all wear and tear parts replaced as well.
HatTrick_SWE is offline   Reply With Quote
Old 03-30-2015, 01:18 PM   #177
Tech Elite
 
JatoTheRipper's Avatar
 
Join Date: Sep 2007
Location: PA
Posts: 2,340
Trader Rating: 7 (100%+)
Default

Quote:
Originally Posted by chktm View Post
Sorry to hear of your dramas. Is this bind severe over the whole travel or just binding around dogbones level? If it's severe over the whole travel I'd say the inner suspension mount is upside down, if it's only around bones level it'll be them. I grind a little off each end until there's no bind. My friend has the universals and I'm sure he didn't have the issue, he didn't mention it anyway.
The bind is pretty constant. I've ensured everything is assembled correctly, including the suspension mounts and transmission.

Can anybody chime in on the paint to match the Kyosho yellow plastic?
__________________
Leaf Spring Mafia - Member #1
https://www.shapeways.com/shops/leafspringmafia
https://www.facebook.com/LeafSpringMafia
https://www.instagram.com/LeafSpringMafia
JatoTheRipper is online now   Reply With Quote
Old 03-30-2015, 01:30 PM   #178
Tech Master
 
kaiser's Avatar
 
Join Date: Sep 2010
Location: new milford ct
Posts: 1,688
Trader Rating: 2 (100%+)
Default

Quote:
Originally Posted by JatoTheRipper View Post
I'm not happy with the low quality of the Scorpion kit at all. People always say how Kyosho kits are the highest quality, but that doesn't apply here.

So far I've had burrs on the metal parts, an unfinished suspension arm, short on hardware, and now this severe bind in the rear suspension.

I've loosened and tightened the suspension mounts and transmission at least 10 times with no success. Any ideas how to fix this? Please help. Thanks.
i would contact kyosho. i had a couple of small issues and they took care of it. i thought the kit was very well made, sounds like you got a lemon.
i had no burrs or anything like that.

i think the car is outstanding. it's fast as hell too. i took it to the local indoor track and while it did struggle with the modern jumps it was awesome everywhere else on the track.
__________________
vintage for life! Jrx2/JrxPro/RC10/RC10ce/RC10 graphite/RC10 oin/RC10T/RC10T2/RCPS sprinter/Optima x2/Scorpion/too many old tamiya's to list
RCHR.biz
kaiser is offline   Reply With Quote
Old 03-30-2015, 03:03 PM   #179
Tech Apprentice
 
Join Date: Sep 2013
Posts: 61
Default

My two builds went without issue but my friend had a small bur in the rear suspension arm that caused a bearing to break while installing.
With the bind try removing the dogbones and check if the problem is gone, if so it must be the cause if it still binds the problem must be elsewhere.
chktm is offline   Reply With Quote
Old 03-31-2015, 02:13 AM   #180
Tech Apprentice
 
Join Date: Sep 2013
Posts: 61
Default

Quote:
Originally Posted by HatTrick_SWE View Post
First post for me on these forums. Just found out today about the Re-released Scorpion.
I have a vintage Scorpion that I got back in '83 from a guy who had been racing with it and done quite a few mods to it as well.
Haven't driven it for maybe 25 years now but I've had the idea back in my head for a long time to put a new gearbox on it to allow for new motors and get it running again.
Last time I drove it, it had a Le Mans 480 Gold motor, 8.4V battery and a mechanical resistor speed-control.

Now I find out that with the re-re they've also made a perfect mod-kit for my old Scorpion as well. Can't wait to get it updated and running again with all wear and tear parts replaced as well.
Have fun getting your buggy back into action.
chktm is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 06:08 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net