R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 05-21-2005, 10:41 AM   #1
Tech Apprentice
Join Date: Apr 2005
Posts: 45
Send a message via AIM to skater-racer
Default engine trouble

alright ill be doing full speed and slow down to turn the engine sounds like its about to go off i bring it in to look at it and it shuts off after like 1 second i just installed a fuel filter i think that might be a problem any sugestions on how to stop it would it help to not run it in grass
skater-racer is offline   Reply With Quote
Old 05-21-2005, 06:25 PM   #2
Tech Master
Team Duratrax's Avatar
Join Date: Aug 2004
Location: NSW, Albury/Wodonga
Posts: 1,674
Send a message via MSN to Team Duratrax

Adjust the idle screw.Turn it in clockwise until you feel that the engine is revving high enough for it not to stall.

Team Duratrax is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
engine trouble kyosho 444 Nitro On-Road 3 04-14-2007 03:47 AM
Engine won't Rev Up and Glow Plug Trouble tarheel23 Nitro On-Road 5 07-25-2006 07:26 PM
Trouble starting engine on a TS-12 IceD Rookie Zone 2 06-09-2005 12:51 AM
engine trouble igkyoa Electric Off-Road 4 12-04-2003 06:03 PM
Engine Trouble (I think?) Plz help! Nitrus~Power Electric On-Road 1 03-15-2003 11:43 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 11:46 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0