R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 10-28-2004, 08:01 AM   #1
Tech Adept
Join Date: Jul 2004
Posts: 127
Arrow GM V3R problems

Hi, I have GM V3R ESC, using it in my Loxi XXX-T.
The servo works fine but the throttle and brake does not work.

Is it possible to reset the V3R ?
The green light comes on when I turn it on, when I brake and throttle the green light stays on.

What could be the problem ?

Plz comment
Snikkari is offline   Reply With Quote
Old 10-28-2004, 05:00 PM   #2
Tech Addict
associatedguy's Avatar
Join Date: Oct 2004
Posts: 714
Trader Rating: 8 (100%+)

you can do one of two things
you can send it back to gm and they'll fix it
or you could just get a new speed control cause them v3r's are junk any way
associatedguy is offline   Reply With Quote
Old 10-29-2004, 02:53 AM   #3
Tech Adept
Join Date: Jul 2004
Posts: 127

Ok, I see.
Does anyone have the address for GM customer services ?
Snikkari is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
b4/t4 problems trdsupra88 Electric Off-Road 12 03-15-2008 09:52 PM
JR Z-1 Problems...need help! pumpkinfish Radio and Electronics 3 10-24-2007 04:31 PM
Problems.. Oasis Chat Lounge 9 01-16-2006 07:41 AM
tc3 one way problems dontfeelcold Australian Racing 7 12-31-2003 03:34 PM
Set Up Problems Griz Australian Racing 5 12-04-2003 11:44 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 07:28 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0