R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 06-09-2011, 03:04 PM   #1
Tech Regular
 
Join Date: May 2010
Posts: 367
Trader Rating: 1 (100%+)
Default Lipo wont charge

I have a Turnigy 35-45c discharge 5000mah lipo that says the balancer doesn't connect when I connect it to the battery charger and then it doesn't charge at all.

Im thinking its an issue with maybe the wiring connections got loose to the balancer.

Anyways can this be repaired or does it have to be thrown out?
JimmyS1985 is offline   Reply With Quote
Old 06-09-2011, 03:06 PM   #2
Tech Master
 
Join Date: Nov 2009
Posts: 1,648
Trader Rating: 20 (100%+)
Default

Quote:
Originally Posted by JimmyS1985 View Post
I have a Turnigy 35-45c discharge 5000mah lipo that says the balancer doesn't connect when I connect it to the battery charger and then it doesn't charge at all.

Im thinking its an issue with maybe the wiring connections got loose to the balancer.

Anyways can this be repaired or does it have to be thrown out?
try charging it in nimah mode for a few min then put it back into lipo mode.if that doesnt work then you have a bad cell/cells
toyota 2jz is offline   Reply With Quote
Old 06-09-2011, 03:07 PM   #3
Tech Addict
 
TailsNeon556's Avatar
 
Join Date: Jun 2010
Location: Flushing, NY
Posts: 641
Default

Quote:
Originally Posted by JimmyS1985 View Post
I have a Turnigy 35-45c discharge 5000mah lipo that says the balancer doesn't connect when I connect it to the battery charger and then it doesn't charge at all.

Im thinking its an issue with maybe the wiring connections got loose to the balancer.

Anyways can this be repaired or does it have to be thrown out?
did you try charging it without the balancer? could be an open in the balancing connector / wiring / port.. it isnt needed all the time.. i almost never balance my packs and haven't had any issues.. when i do throw it on .. they are very close
__________________
Derek Lombardi
Kyosho RB6 - Kyosho RB5 SP2 WC +15 - Kyosho Lazer ZX-5 FS2 - Kyosho MP9 TKI2
Island Raceway & Hobby - PCR bodies
TailsNeon556 is offline   Reply With Quote
Old 06-09-2011, 04:39 PM   #4
Tech Initiate
 
Join Date: Jun 2011
Posts: 31
Default

just return it and see if they take it back.
rsmugs is offline   Reply With Quote
Old 06-09-2011, 04:48 PM   #5
Tech Champion
 
Matt Howard's Avatar
 
Join Date: Aug 2001
Location: Abilene TX
Posts: 5,952
Trader Rating: 6 (100%+)
Default

Quote:
Originally Posted by rsmugs View Post
just return it and see if they take it back.
return it back to Hobbyking? yeah, good luck with that
__________________
Official member of The Guild of Calamitous Intent and proud supporter of Conjectural Technologies.
Serpent S411 LE kit #192
RCTech #361
Matt Howard is offline   Reply With Quote
Old 06-09-2011, 04:53 PM   #6
Tech Regular
 
Join Date: May 2010
Posts: 367
Trader Rating: 1 (100%+)
Default

I tried hooking it up without the balancer but it did not work.
JimmyS1985 is offline   Reply With Quote
Old 06-09-2011, 05:08 PM   #7
Tech Addict
 
TailsNeon556's Avatar
 
Join Date: Jun 2010
Location: Flushing, NY
Posts: 641
Default

Quote:
Originally Posted by JimmyS1985 View Post
I tried hooking it up without the balancer but it did not work.
Then it sounds like you have an open in the pack somewhere.. if you hook up a voltmeter do you get a reading?
__________________
Derek Lombardi
Kyosho RB6 - Kyosho RB5 SP2 WC +15 - Kyosho Lazer ZX-5 FS2 - Kyosho MP9 TKI2
Island Raceway & Hobby - PCR bodies
TailsNeon556 is offline   Reply With Quote
Old 06-09-2011, 06:18 PM   #8
Tech Initiate
 
Join Date: Jun 2011
Posts: 27
Default

Try charging it at .0x (x being the 5 in 5000mah)

so if its 5000 MAH, charge at .05 mah
amagad is offline   Reply With Quote
Old 06-09-2011, 07:08 PM   #9
Tech Champion
 
Briguy's Avatar
R/C Tech Elite Subscriber
 
Join Date: Aug 2006
Location: Ottawa , IL
Posts: 8,128
Trader Rating: 125 (100%+)
Send a message via Yahoo to Briguy
Default

Check the lipo with a meter to see if it reads both cells .
__________________
At Your Service Vinyl Works
Royal R/C & Hobby
Leisure Hours Hobby & Raceway
Briguy is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
lipo wont charge microbomb Electric Off-Road 6 06-10-2010 03:12 PM
New Turnigy Lipo wont charge fievel Electric Off-Road 9 05-08-2010 01:32 PM
My Lipo wont balance. Is it the charger or the lipo RaV3N Electric Off-Road 40 12-25-2009 01:49 PM
Lipo-no power-wont charge mach1rustler Radio and Electronics 10 08-20-2009 04:57 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 08:47 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net