R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Reply
 
Thread Tools Search this Thread
Old 10-16-2010, 02:11 PM   #1
Tech Regular
 
Join Date: Aug 2009
Posts: 258
Trader Rating: 17 (100%+)
Default Strange Truggy Problem

When ever I get on the throttle while turning left, it will straighten out and not turn, even with my radio at full lock left. Off power it seems to turn normal. Has anyone had an issue like this? It worked fine yesterday, then I put in a front smart diff and a different servo, but that servo was too much and made the whole truck stutter on and off. So I put the original servo in and now this. Any ideas? I tried 2 different batteries and made sure connections were tight.
Trialser is offline   Reply With Quote
Old 10-16-2010, 02:54 PM   #2
Tech Regular
 
Join Date: Aug 2009
Posts: 258
Trader Rating: 17 (100%+)
Default

I just tried a different receiver, same thing. Then I tried recalibrating, now it does the same thing in both directions and everytime i blip the throttle the steering will go either way. Also, when I turn it on, with each beep the esc makes, the servo will go back and forth. Forgot to mention, I am running a MMM combo with Hitec servo. I cant think of anything else to try, and help would be greatly appreciated.
Trialser is offline   Reply With Quote
Old 10-16-2010, 03:05 PM   #3
Tech Adept
 
mister-e-meat's Avatar
 
Join Date: Sep 2009
Posts: 190
Trader Rating: 5 (100%+)
Default

sounds like your servo saver try tightening it a little thread lock should hold it in place.
__________________
its easier to make excuses than laps...
mister-e-meat is offline   Reply With Quote
Old 10-16-2010, 03:11 PM   #4
Tech Regular
 
Join Date: Aug 2009
Posts: 258
Trader Rating: 17 (100%+)
Default

I took the servo horn off and could still see the servo moving. It's like the trottle trigger is telling it to go and turn at the same time.
Trialser is offline   Reply With Quote
Old 10-16-2010, 07:50 PM   #5
Tech Regular
 
Join Date: Aug 2009
Posts: 258
Trader Rating: 17 (100%+)
Default

Would a glitch bister solve this?
Trialser is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hot Bodies D8 Truggy Greg B Nitro Off-Road 10028 08-16-2017 05:44 PM
Truggy bodies? DOMIT Nitro Off-Road 49 01-20-2010 06:17 PM
Help my throttle servo hums when i turn on the truggy GASMAN123 Nitro Off-Road 18 09-27-2009 11:31 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:04 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net