R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 04-07-2009, 01:26 PM   #16
Tech Master
Kings Kid's Avatar
Join Date: Sep 2005
Location: sw lower michigan
Posts: 1,681
Trader Rating: 35 (100%+)

sounds like a small pebble in between the gears on the spur.
Kings Kid is offline   Reply With Quote
Old 04-07-2009, 09:16 PM   #17
Tech Initiate
RallyImp05's Avatar
Join Date: Mar 2009
Posts: 44

well i pulled everything apart, tranny, diff, everything. there were a couple pebbles in the spur, cleaned them out. no other abnormalities and the motor sounded fine, so im thinking that was the problem. only ran it for about 10 seconds but it sounded fine to me. good to know for the future.
Traxxas Slash VXL
RallyImp05 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Outdoor FREE Slash track in Seattle t0adman Northwest Racers 4229 09-07-2016 01:41 PM
Traxxas Slash, SETUPS ONLY ! ! ! ! ! nobike Electric Off-Road 769 09-13-2014 02:35 PM
MY slash is going in the trash Leroy1234p Electric Off-Road 53 07-10-2009 08:22 PM
I got a huge problem with my slash Leroy1234p Electric Off-Road 30 05-06-2009 05:04 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 05:49 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0