R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 01-28-2009, 08:24 PM   #31
Tech Regular
Joe Ford's Avatar
Join Date: Nov 2006
Location: Olathe, KS
Posts: 284
Send a message via AIM to Joe Ford

Don't cheap out on the batteries guys...we can't stress that enough. You've got this beautiful $350+ ride, a $250 system for it, and then to power it use so-so batteries. The system is only going to be as good as the batteries powering it. Also, ripple current causes more ESCs to fail than anything else. This phenomenon takes place when the ESC is switching on and off thousands of times per second. The batteries obviously cannot do that so the capacitors store a charge to get the ESC through this, and smooth the current and voltage out. If the batteries cannot provide enough voltage/current to keep the capacitors charged, the caps keep trying to dump but there's nothing in them...they get hot, and if they get hot enough the electrolytic fluid inside boils and the cap fails. When this happens your ESC is open to those huge current swings and it'll go up in smoke. We will not cover the ESC under warranty due to inadequate batteries. 4000mah 20C is the absolute minimum. The higher those #'s are the better. I personally don't use anything less than 5000mah 20C, or go up to 4500 30C. My .02
Joe Ford
Product Specialist
Castle Creations
Joe Ford is offline   Reply With Quote
Old 01-28-2009, 11:59 PM   #32
Tech Master
onefast8's Avatar
Join Date: Jan 2009
Location: AZ
Posts: 1,434
Trader Rating: 41 (100%+)

Thanks for the info Joe!

Makes a bit more sense now.
onefast8 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
W.E.D. Winning Edge Designs questions and comments... W.E.D.Jim Painting, Designs, Graphics and Photography 3693 Today 07:12 AM
Mugen MBX6 teeforb Nitro Off-Road 18539 03-20-2016 02:59 PM
New Hot Bodies Buggy!!??????? monsteraddict Nitro Off-Road 14489 03-18-2013 01:42 PM
Ok I give in. 1/8 brushless qustion's. j.d.roost Electric Off-Road 46 07-08-2009 07:29 PM
B4...lipo or not? (setup questions) CaptainHowdyt13 Electric Off-Road 33 02-09-2009 10:26 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 03:21 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0