R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 08-22-2008, 09:17 PM   #1
Tech Rookie
Join Date: Aug 2008
Posts: 1
Default brushless savage

just put togeather a twin brushless savage with 2 feigao 6xl's and 2 mamba monsters on 5s maxamps its all calabrated but when i trottle or brake the fan on the esc runs but the motors dont turn ..............any help out there ,.........
yolonda21 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Grande Prairie Model Racers Association WheelNut Canadian R/C Scene 19799 09-30-2016 08:26 AM
RC10B4/T4 Forum DerekL Electric Off-Road 14331 01-01-2016 02:18 PM
Transitioning from nitro. What should my first car be? sokar Electric Off-Road 42 08-05-2009 07:12 PM
Looking to buy a basher. tmcquaig Monster Trucks 30 05-26-2009 12:02 PM
savage flux or stampede vxl? grave digger Electric Off-Road 14 04-22-2009 07:50 PM
converted nitro(FLM hpi race Savage X SS brushless) edep345 R/C Items: For Sale/Trade 8 12-21-2008 11:15 PM
E-Savage or E-Maxx lethal19 Monster Trucks 28 12-09-2008 11:00 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 12:22 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0