R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 04-13-2008, 06:24 PM   #1
Tech Addict
beez's Avatar
Join Date: Mar 2008
Posts: 678
Trader Rating: 4 (100%+)
Default Novak Brushless 13.5 problem

ESC: Novak GTB
Motor: Novak BL 13.5

At first, sometimes there would be a delay between pulling the trigger, and the car getting power from a dead stop. I'm not talking about a slight delay, I'm talking about a full 3 count sometimes. And occasionally the car was short on punch to the point where I just didn't have enough to clear a double that I was clearing easily before.

After awhile, it was no longer a delay, it was just dead. Then I noticed that the times that it wouldn't restart were times when it stopped spinning in the same spot (the flat side of the rotor facing towards the back of the car) and if I gave it a little push with my fingers, it would start moving.

We took it apart and sprayed it out (thanks John Sterling), no change, so I don't think it's dirt inside the motor. I'm new to brushless, but my theory is that there is a sensor out in that spot.

Does anyone have any ideas? Are the sensors replaceable? Am I doomed to buy a new motor? Should I just wait until monday and call novak?

Thanks for reading,

beez is offline   Reply With Quote
Old 04-13-2008, 06:34 PM   #2
Tech Elite
SWTour's Avatar
Join Date: Sep 2003
Location: Central Coast...CALIF.
Posts: 2,803
Trader Rating: 9 (100%+)

...I'd call NOVAK and talk to Charlie.

I've heard a few of these stories...but I don't recall what the answer was.
Joe Myers
R/C Racing since 1985 ~ Santa Maria, CA (Central Coast)
2001-2012 - South-West Tour R/C Oval Series - R.I.P.
...will the SWT be revived? Time will tell, but we ARE returning to the VELODROME in 2016
SWTour is offline   Reply With Quote
Old 04-13-2008, 06:37 PM   #3
Tech Elite
gone banana's Avatar
Join Date: Nov 2002
Location: wisconsin
Posts: 2,272
Trader Rating: 14 (100%+)
Default Novak BL 13.5

i had a problem like with my gtb and 4300 i noticed it was stalling i change the rotor in my
just make sure your end points on the radio are set right and try to reprogram it if that does not work you might have send in

Last edited by gone banana; 04-14-2008 at 04:54 AM. Reason: missed word
gone banana is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
novak brushless motor problem ? stew215 Radio and Electronics 3 02-17-2008 09:12 AM
Novak Brushless problem shooter26 Electric On-Road 8 09-24-2007 02:27 PM
Novak Brushless Problem LClarke Electric Off-Road 3 05-14-2006 09:42 AM
Novak Brushless Problem revzalot Electric On-Road 9 09-01-2004 08:01 AM
Problem with Novak SS Brushless System DraKhen99 Electric On-Road 3 07-24-2003 07:05 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 10:39 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0