R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 11-10-2007, 05:44 PM   #1
Tech Elite
K_King's Avatar
Join Date: Jul 2006
Location: San Diego, CA
Posts: 4,127
Trader Rating: 37 (100%+)
Send a message via AIM to K_King
Default Uhh dead ESC or..

I was sitting here setting my trim on my T4, took it out for a spin and didnt like the sub trim being at 15, so as I was shorting up the link, it just took off into my left full wood. I turned it off, and yeah it was posessed even off it was full wood. Rest the 2.4GHz stuff, reset the ESC (GTB Spectrum) and no dice. Then I smelt what I think is burnt electronics.

Im guessing a dead GTB?
TLR - Spektrum - Pro-Line - Stickit1- Schelle - B-Fast Performance
K_King is offline   Reply With Quote
Old 11-10-2007, 05:47 PM   #2
Tech Fanatic
ray3619's Avatar
Join Date: Dec 2004
Location: glendale az
Posts: 997

sounds like it , get it sent in , novak will treat you right , ray
ray3619 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
MT class dead? Flying Monkey Georgia Racing 16 10-16-2007 08:50 PM
Dead KaT sgoodlund Northwest Racers 37 10-02-2007 09:08 AM
Is rc dead? crazy8ight Northwest Racers 39 07-31-2007 12:14 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 07:11 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0