R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 10-22-2007, 07:46 PM   #1
Tech Initiate
Join Date: Oct 2007
Posts: 23
Default Servo making funny noises (is it broken?)

I recently purchased this servo for my T4: http://www3.towerhobbies.com/cgi-bin...1&I=LXUZ87&P=K

It came in the mail today and I installed it on my truck. As soon as I powered on, the servo started to vibrate. If I turn right or left and hold it, something inside the servo continues to vibrate. If I let the servo center itself, it continues to vibrate from within. I can get it to stop by twitching it a bit to get it to center again, but as soon as I turn it starts to vibrate again.

Is the indication that the servo is defective? The gears sound like they work fine, and it is brand new. It seems odd, but maybe this is standard behavior for this servo, can anyone shed some light onto this for me?
Imperator is offline   Reply With Quote
Old 10-22-2007, 08:10 PM   #2
Tech Adept
johnkemp's Avatar
Join Date: Apr 2007
Location: mildura
Posts: 141
Trader Rating: 2 (100%+)

does it keep moving while your not touching the controler
johnkemp is offline   Reply With Quote
Old 10-22-2007, 08:13 PM   #3
Tech Initiate
Join Date: Oct 2007
Posts: 23

If I let it center itself it keeps vibrating without me touching the controller. It does not seem to be moving the gears, something inside of it is vibrating, best way I can describe it.
Imperator is offline   Reply With Quote
Old 10-22-2007, 08:16 PM   #4
Tech Champion
air8's Avatar
Join Date: Apr 2007
Location: Hutch, KS
Posts: 5,748
Trader Rating: 7 (100%+)

Do you mean buzzing? Most all servos will buzz when they are in operation. If it is buzzing quite a bit at center try removing the servo horn. Does the buzzing stop? If so then the steering link might need adjusted to take the tension off the servo. There is something pushing on the servo at idle.
--Driver...you are cleared into the track.....Smoke On.

--"U Ain't Fast!!"
Chris Pearce
air8 is offline   Reply With Quote
Old 10-24-2007, 08:33 AM   #5
Tech Champion
BuggyKing's Avatar
Join Date: Oct 2006
Location: Huntington Beach, Ca
Posts: 7,919
Trader Rating: 17 (100%+)

servos make noise when in use and when you lock out the steering it makes another noise.
Our government is a #$%$ joke, from the head jester on down
RIP Mike M
BuggyKing is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Should a new 120$ servo be making this noise? srac cr ot wen Nitro Off-Road 9 07-17-2008 12:29 PM
Hitec Digital Servo making SOS noises..!!! Mpowerz Nitro Off-Road 12 01-12-2008 01:49 PM
Servo Broken? ttektek Nitro On-Road 1 03-16-2003 04:24 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 06:46 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0