R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 12-30-2006, 01:13 PM   #1
Tech Master
Join Date: Dec 2006
Location: Coral gables, Florida
Posts: 1,265
Trader Rating: 18 (100%+)
Send a message via Yahoo to infanterene
Default JR DS8611a servo problem?

I bought 2 Ds8611a servos. 1 for a muggy and the second for a Losi 8 rtr. Both of them seem to turn more in one direction than the other. Has anyone experinced anything like this? Also they seem real slow, I am running them at 6v so spec say they should be .15 but the seem slower that the cheap servos they replaced.
infanterene is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
SERVO PROBLEM lancerevo22194 Micro and Mini Scales 11 07-23-2008 03:17 PM
servo problem. Please help! cars.cars.cars Nitro On-Road 4 08-22-2005 12:02 AM
servo problem wothrottle Electric On-Road 0 09-29-2004 05:24 AM
servo problem wahturi Nitro On-Road 7 12-25-2002 09:48 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 07:48 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0