R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 07-26-2006, 07:26 PM   #1
Tech Rookie
Join Date: Jul 2006
Posts: 2
Default New guy here..

Just joined the site and thought I would say hi and ask a few questions.. Can anyone tell me what happened to my speed controll??? Had 2 of em melt on the same car they both worked well for a while then up in smoke??? The truck has a 27 turn epic motor and traxxas reciever2215 in a losi jrx2... Btw I know nothing about r/c cars just learning..
Attached Thumbnails
New guy here..-model-blazer-011.jpg  
frenchblue72 is offline   Reply With Quote
Old 07-26-2006, 08:09 PM   #2
Tech Elite
xlgraphicspro's Avatar
Join Date: Dec 2004
Location: Omaha Nebraska
Posts: 2,052
Trader Rating: 3 (100%+)

Dude, I believe your picture just told me to Kill! Slightly Subliminal! Also I think there is a rookie or noob thread somewhere here, that would be a good place to start asking questions! Also, that speed control looks rather old. Novak T-4 or so? I think you might want to up grade!
TeamXray RCAmerica Hudy Xlgraphicspro Paint/ Impulse-Rc Clutch shoes.
Xray XB 808 O.S. Speed Or Ninja JX
xlgraphicspro is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 02:30 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0