R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 07-25-2006, 03:14 PM   #1
Tech Rookie
Join Date: Jul 2006
Posts: 1
Default Overstear Problem

I have a almost stock Pede:Team Orion 19t,,87tspur,16t pinion,stock tires&lotts of overstear..Any Ideas??????
Brand is offline   Reply With Quote
Old 07-25-2006, 03:32 PM   #2
Tech Master
Join Date: Jan 2006
Location: Richland, WA
Posts: 1,675
Trader Rating: 6 (100%+)

camber, toe, epa, , check thoeo.
gatermaxx is offline   Reply With Quote
Old 07-26-2006, 06:14 AM   #3
Tech Adept
Join Date: Apr 2005
Location: Montreal
Posts: 117
Trader Rating: 2 (100%+)

Don't forget the jiggling pin adjustment....
b4zed is offline   Reply With Quote
Old 07-26-2006, 06:47 AM   #4
Tech Elite
Join Date: Jun 2005
Posts: 2,570
Trader Rating: 26 (96%+)

If the front end is the sluggish end then move the shock mounting location out one hole on the a-arm. If it is the rear end then do the same.
party_wagon is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
dx3 problem banshee_317 Radio and Electronics 8 07-13-2008 06:50 PM
KO PRO PO VSF-1 PROBLEM mazmo Australian Racing 4 07-24-2005 06:38 AM
Big Problem!!1 doublest Electric On-Road 8 05-13-2003 01:01 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 05:36 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0