R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 02-26-2006, 05:00 PM   #1
Tech Rookie
Join Date: Feb 2006
Location: Virgina
Posts: 2
rc10gt, idle probs. new 2 nitro

kinda new to the nitro world. i bought a new rc10gt W/ae t.15 engine. i broke it in according the book. runs good and fast response. but after it warms up good (not overheating) the idle will creep up on it. if i smack the thottle it will fall back down to normal but a few seconds later it creeps up again? please help i'm lost... p.s. when i say creep i mean like 1/4 thottle up.
parisherj is offline   Reply With Quote
Old 02-26-2006, 05:50 PM   #2
Tech Regular
Join Date: Nov 2004
Location: ep nj
Posts: 403

might have an air leak http://www.rchobbies.org/engine-tuning.htm or is out of tune http://www.rchobbies.org/cars_eng-tuning.htm
mgtman is offline   Reply With Quote
Old 02-26-2006, 09:04 PM   #3
Tech Master
Join Date: May 2005
Location: michigan
Posts: 1,678
Trader Rating: 14 (100%+)

when you say smack the throttle - do you mean you are hitting the brakes?

If you are - pop off the airfilter and see if the carb is open when at the idle position. You don't do this with the truck running, and make sure the air filter boot and surrounding areas are clean.

Sometimes the linkages on RTR's are not set correctly from the factory. When the trigger on the transmitter is in neutral, the servo horn might not be centered on the servo itself and could be holding the carb open.

If that seems to be the case someone can eloborate more on how to center the servo and servo horn later - not trying to confuse you.
o.s. power is offline   Reply With Quote
Old 02-27-2006, 04:19 PM   #4
Tech Rookie
Join Date: Feb 2006
Location: Virgina
Posts: 2

thanks for the replys guys.. when i say smack the throttle i mean like a fast throttle up.not brake.. i can hold the brake when it starts acting up and it does nothing. i watch the servos and as the idle climbs the servo does'nt move.. nor does the linkage. seems to be all in the motor or carb. i dropped it off at the local hobby shop. there baffled too.. said it they can't figure it out they will replace the carb under warranty.
parisherj is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nitro buggy won't Idle dan_allen_1 Electric Off-Road 3 02-25-2006 12:55 PM
Help with Nitro Evader ST Idle mkimmer Electric Off-Road 6 02-25-2006 12:39 PM
nitro evader tranny probs, please help!!! xmodster1 Electric Off-Road 7 01-16-2006 07:58 PM
t-maxx idle probs! help! Johnathan Monster Trucks 4 07-30-2005 09:27 PM
RC10 GT starting probs/idleing probs Smoke21 Electric Off-Road 3 07-13-2004 10:03 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 10:57 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0