R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric Off-Road

Thread Tools Search this Thread
Old 02-15-2006, 05:48 PM   #1
Tech Rookie
Join Date: Feb 2006
Posts: 12
Default need tech help please

Have you ever went to your LHS planning on buying just a ready to run kit.Then get tired of that and get the better kit.then you have gotta have all the better stuff for that better kit.Well thats what im doing now.It seems the more better stuff i buy the more worse problems i have.Here's what i have now--- team losi mf2 kit,novak gtb w/5.5r brushless set-up,spektrum dx3 setup.The problem im having is that when I pull the throttle slowly everything works great most of the time.when I go from nuetral to fast full throttle the receiver loses power and takes a second to come back on,then repaets the process.The whole time it only moves about an inch or so.I had the cheaper venom 3000mah batteries and tried a friends more expensive matched cell batteries and it seemed to be straight for about 2 minutes then it does the same thing.Ichecked my battery connections and the connections going to the speed control and everything looked fine.the pinion gear is a 15 tooth and the spur is an 87 tooth.we tested it with a battery pack plugged in like a nitro car uses and there is no problems whatsoever.i then tested it with a 2200uf cap plugged into the receiver batt spot .it worked fine for about 5 minutes then started acting the same way.spektrum r/c sells a capacitor setup for low voltage applications, its recommended for 1/12 scale carpet.but i am running it on a xxx-t .please if anyone has any experience at all with this please respond or pm me.
PLANETSTEREO is offline   Reply With Quote
Old 02-15-2006, 06:00 PM   #2
Tech Regular
Join Date: Dec 2005
Posts: 337

did you try reprograming the gtb, start with the obvious stuff, check to make sure a wire goes to a hole on motor and so on for b and c. also make sure that no solder is in the small spot between the external tabs on the motor which happened on mine and i couldnt figure out what was going on and was about to send it novak when i realized the solder was ther and shorting those two wires.
lp1066 is offline   Reply With Quote
Old 02-15-2006, 06:12 PM   #3
Tech Rookie
Join Date: Feb 2006
Posts: 12

i got the gtb 5.5 system that was presoldered together.
PLANETSTEREO is offline   Reply With Quote
Old 02-15-2006, 09:02 PM   #4
Tech Addict
Join Date: Feb 2006
Location: Canton, MI
Posts: 500
Send a message via AIM to RcCzarOfOld Send a message via MSN to RcCzarOfOld Send a message via Yahoo to RcCzarOfOld

The problem isn't with your GTB at all. Is this a very early version Spektrum system? They had a lot of problems with the early systems doing exactly what you're talking about. What happens is that your motor is drawing so much amperage that the RX goes into fail safe mode. There's not enough power to keep it on. I think you can send it in for a reprogram. Check the Spektrum site to be sure or give them a call. You can also try changing the RX for a new one. But most likely, you're going to need to get the cap that Spektrum offers. It'll compensate for the momentary loss of power when your motor is pulling major amperage like on take off or when you're hard on the power coming out of corners.

RcCzarOfOld is offline   Reply With Quote
Old 03-01-2006, 03:11 AM   #5
Tech Elite
MadRacer's Avatar
R/C Tech Elite Subscriber
Join Date: Aug 2005
Location: Australia
Posts: 2,665
Trader Rating: 31 (100%+)
Default Spectrum

I think it's the Spectrum reciever i had all sorts of problems with myne untill they replaced the whole system.. Try the original reciever..
Boondal vintage Tamiya's


QLD State Titles winner in 6S EB CAT
MadRacer is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
hey rc tech!!! crawlercrazy R/C Tech Site Forum 3 08-12-2008 06:54 AM
@@@@@@looking for a GO Tech .21@@@@@@ losi 8t R/C Items: Wanted to Buy 3 06-30-2008 02:49 PM
Go-tech 3 or O.S. VG? Furadi Nitro Off-Road 19 03-19-2008 04:03 PM
To tech or not to tech, Thats is the question David Butts Electric On-Road 15 12-18-2007 11:17 PM
LRP or Go Tech? sir miles Nitro Off-Road 5 08-26-2007 06:35 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 07:59 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0